«
  
»

! To perdidão em lógica! Elabore uma sub-rotina que receba dois números escolha o símbolo da operação(+ ou *) efetue a adição ou multiplicação mostrando o resultado dela ao final. Desenvolva uma sub-rotina que receba um valor em uma temperatura em graus Celsius e converta em temperatura em graus Fahrenheit. No Visualg(ferramenta usada ao decorrer do curso) função ou procedimento podem receber vetores/matrizes por parâmetros? Por que?



RESOLVENDO

algoritmo "dois_numeros"

var

x, y: inteiro

resultado: inteiro

funcao somadoisnum (numero1, numero2: inteiro): inteiro

var

soma: inteiro

inicio

soma <- numero1+numero2

retorne soma

fimfuncao

funcao multiplicaodoisnum (numero1, numero2: inteiro): inteiro

var multiplicacao: inteiro

inicio multiplicacao <- numero1*numero2

retorne multiplicacao

fimfuncao

inicio

escreval("Soma de dois números")

escreva("Informe o 1º número:")

leia(x)

escreva("Informe o 2º número:")

leia(y)

resultado <- somadoisnum(x, y)

escreval("A soma é:", resultado)

resultado <- multiplicaodoisnum(x, y)

escreval("A multiplição é:", resultado)

fimalgoritmo



O que achou desse conteúdo? Deixe seu comentário
TAREFAS SIMILARES: